请选择 进入手机版 | 继续访问电脑版

LuaFunc-0.lua 中能用require吗

[复制链接]
作者: 复制粘贴就是干 | 时间: 2023-1-12 15:39:15 | 技术答疑|
8 1053

29

帖子

2497

金币

1391

积分

积分
1391
发表于 2023-1-12 15:39:15| 显示全部楼层 |阅读模式

马上注册,下载996引擎,与更多游戏开发者交流。

您需要 登录 才可以下载或查看,没有帐号?注册

x
LuaFunc-0.lua 中能用require吗?如果可以用的话,该如何使用呢

最后回复时间:2023-01-12 17:30:20官方回复了此贴
回复

使用道具 举报

8464

帖子

1万

金币

1万

积分

积分
12709
发表于 2023-1-12 17:30:20| 显示全部楼层
本帖最后由 996技术-wang 于 2023-1-31 09:22 编辑

可以用的
回复

使用道具 举报

121

帖子

4985

金币

2906

积分

积分
2906
发表于 2023-1-13 14:37:16| 显示全部楼层
只要是Lua文件,都可以用require
回复

使用道具 举报

29

帖子

2497

金币

1391

积分

积分
1391
 楼主| 发表于 2023-1-13 23:49:28| 显示全部楼层
shenyue 发表于 2023-1-13 14:37
只要是Lua文件,都可以用require

996的require封装了。。不知道封装了啥内容
回复

使用道具 举报

121

帖子

4985

金币

2906

积分

积分
2906
发表于 2023-1-16 15:41:39| 显示全部楼层
复制粘贴就是干 发表于 2023-1-13 23:49
996的require封装了。。不知道封装了啥内容

require 重写了,和Lua原生的require不一样,有区别
回复

使用道具 举报

121

帖子

4985

金币

2906

积分

积分
2906
发表于 2023-1-16 15:41:56| 显示全部楼层
复制粘贴就是干 发表于 2023-1-13 23:49
996的require封装了。。不知道封装了啥内容

主要就是为了防止注入
回复

使用道具 举报

29

帖子

2497

金币

1391

积分

积分
1391
 楼主| 发表于 2023-1-16 18:51:26| 显示全部楼层
shenyue 发表于 2023-1-16 15:41
主要就是为了防止注入

反正我在LuaFunc里面require没用,而且好多方法都不支持。。。。感觉就只能做做排序啥的
回复

使用道具 举报

90

帖子

2105

金币

1177

积分

积分
1177
发表于 2023-1-28 11:13:57| 显示全部楼层
用include
回复

使用道具 举报

2

帖子

631

金币

339

积分

积分
339
发表于 2024-5-6 23:03:12| 显示全部楼层

require 和 include 在引擎有什么区别。  给Lua的require封装加功能好理解,为啥还要再加个 include。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

24小时热门更多>
快速回复 返回列表 返回顶部